Loading .deepar file from local giving memory access out of bounds issue

Loading .deepar file from local giving memory access out of bounds issue.

  1. I tried loading the effect from deepar provided link → succeeded.
  2. I tried loading effect by loading the .deepar file copied into assets of project → Failed, giving memory access out of bounds issue
  3. I tried loading the effect with a google drive/dropbox url → Failed, giving error saying unable to fetch from the link and also the url showing 302 error while runtime

Hey @nareshpendamuvenu, welcome to the forum!

It sounds like DeepAR is not able to access your effect file in scenario 2 and 3.

If you want to load your file from within the project, just make sure it’s in a folder that can still be accessed on run time - which is commonly in the /public/... folder. Then you just need to make sure the link is working as you expect. You can test this by trying to access the file from your browser - ie localhost:3000/public/my-effect.deepar - if you are able to download it this way, it should work.

If you want to load the .deepar file from outside of your project (best if you have many files to avoid bloating the code repository), most people use cloud storage such as an S3 bucket from AWS or Google Cloud Storage.

Let me know if any of that helps. If not, could you share more about your project? A code snippet from where you are applying the .deepar file, and some info about your project structure would be really handy.



1.I tried the loading this effect from deepar test link —>it is working there
2.Loading the .deepar file to Azure blob and giving the blob link to the effect
3.But it is throwing this error Uncaught Runtime Error: table index is out of bounds

Hi, sorry I’m not sure how exactly why this may be happeing it could have something to do with azure itself. There is and integration example here

and it seems using links is reccomended