Got error when trying to make 3 products try on

I downloaded an quick start github repo and sometimes it works but sometimes not and give me the following error

Cannot read properties of null (reading ‘callbacks’)
TypeError: Cannot read properties of null (reading ‘callbacks’)
at main (webpack://sky-dm-2/./src/index.js?:225:10)

on this line in index js: deepAR.callbacks.__deeparRendered = function () {…}

Hi, which example is this happening with?

It happens in quickstart-web-ad repo

Hey @Dalia_Alawneh

Thanks for sharing which example project you had the issue with.

It sounds like the issue you’re facing was that DeepAR failed to initialize, which caused the app to throw an error when it tried to assign the DeepAR callbacks.

We’ve just updated the example project to only attempt to assign the callbacks if DeepAR successfully initializes, but there may still be other errors if DeepAR is failing to load.

Could you try running npm run build and then npm run dev again to see if that fixes it? There’s a bit of a quirk with the project setup currently and this could help solve the issue you’re experiencing.

If that doesn’t help, and you still get the error, could you share more of the console logs you see in the browser?


i have tried the method you said npm run build is working in localMachine and the output is running without any error so again i tried to deploy it then i’m still facing the same error that saying comand npm run build error i’ll add an attachment of error for your reference please look at it

This likely means the copyfiles package is not installed properly. Try reinstalling it.