GLTF export missing faces

Hi there, I am new to DeepAR, and I’ve recently run into a problem regarding 3D model exporting. When I export my GLTF file into DeepAR, there is an issue with some of the faces going missing. Some materials also don’t get applied onto the 3D models inside DeepAR.

This is what is turns into in DeepAR

These are some of the actions I tried to take to solve the problem but to no avail :

  • Exported as FBX (same issue)
  • Recalculated normals (Inside and Outside)

I’m wondering if I am missing something, as even in the GLTF viewer, the 3D model maintains all its faces, only in DeepAR I run into this problem. It would be helpful to understand what the best export settings would be when exporting from Blender to DeepAR.

Hi we have guidelines here.

Could you share a sample model? From the looks of the screenshot I can only assume that you may have multiple meshes on the same node and only the first is being displayed. In that case the fix would be to create separate nodes for each mesh.

Hello, sorry about that, I will adhere to the guidelines better next time!

I have shared the link to the files below. Please note that I have tested the 3D models in Unity as well and they don’t have any missing faces. I am wondering if there are any settings that I need to apply specific to DeepAR. I cannot share the files here because I don’t have the permissions to do so.

Hi, it seems that studio loads the FBX correctly for me. Are you sure you’re on the latest version of the Studio?

Screenshot 2024-01-11 at 21.40.08