How to Fix the model hiding my face

hey, I am new to deepAR studio and AR in general and am working on a web project for a hackathon which has a feature of hairstyle tryon and after a bit of digging, I came across some hairstyle models and imported the .fbx in resources. now when i adjust the hairstyle model in viewport according to the head and preview it It tracks my head and all fine but it hides the face and i dont seem to get the perfect alignment of the model on head.


In order for your effect to work properly you need to place a head occluder which will occlude the back of your hair model. You can add the occluder from the menu Add > Mesh > Head Occluder. Turn off the Color and Alpha write for the material used.

You can check out the documentation for some guidelines about model preparation, virtual try-on, and occluder creation.

Hi, Thanks for your time and reply
I figured it out using the viking helmet template and building over it.

1 Like